
 IconWorks Help
The Index lists Help topics available for IconWorks.    Use the scoll bar to see entries not 
currently visible in the Help window.

To learn how to use Help, press F1 or choose Using Help from the Help menu

Editor
Keyboard
Commands
Status Area
Tool Palette
Color Palette
Defining Colors

Viewer
Keyboard
Commands
Viewing Icons
Selecting Icon to edit

IconWrks.INI File



Initialization File: ICONWRKS.INI
When you close the Editor or Viewer, all settings - with the exception of current Color Palette
setings - are saved to ICONWRKS.INI in your Wndows directory.    To save color settings, 
choose the Save Color palette to INI File command from the Color menu.

The ICONWRKS.INI flag is an ASCII text file, which should not be edited since values read 
from this file are not validated.    Items can be deleted from the file, but not modified.

The following information is saved to the ICONWRKS.INI file:

Editor:

Visibility state of the Status Area
Visibility state of the Tool Palette
Visibility state of the Color Palette
Visibility state of the Zooming Scroll bar
Visibility state of the grid
Status of the Grid type:

Line Grid
Dotted Grid

Status of the Focus to Editor flag
Status of the Display Icon Border flag
Status of the Tools Pop-up Menu flag
Current Color Palette values
Current Color Palette: 

Default Colors
Solid Colors
INI File Colors

Viewer:

Status of Show Icons on DIR change flag



Keyboard - Editor
Press: To choose:

Shift+F12 File Save
F12 File Save As
Alt+F4 File Exit

Alt+BackSpace Edit Undo
Shift+Del Edit Cut
Ctrl+Ins Edit Copy
Shift+Ins Edit Paste
Ctrl+Shift+Ins Edit Opaque Paste
Del Edit Delete
Ctrl+A Edit Select All
Ctrl+H Edit Flip Horizontal
Ctrl+V Edit Flip Vertical
Ctrl+L Edit Rotate Right
Ctrl+R Edit Rotate Left
Ctrl+I Edit Invert

Ctrl+S View Status bar
Ctrl+T View Tool Palette
Ctrl+C View Color Palette
Ctrl+Z View Zoom Scroll bar
Ctrl+G View Grid
Ctrl+F11 View Zoom In
Ctrl+F12 View Zoom Out

F1 Help Index



Commands - Editor
File Menu
Edit Menu
View Menu
Tools Menu
Icons Menu
Color Menu
Brush Menu



File Menu    - Editor
New

Starts a new icon in the currently selected iconbox within the Status area.
When you choose New, IconWorks lets you save changes to the current icon if changes 
were made since it was last saved.      The editing area is cleared to the currently selected 
screen color, and the filename in the Title bar is changed to [Untitled].

Open
Opens the IconWorks Viewer, enabling you to view your icon files.
From the Viewer, you can select and open icons to edit.

Save
Saves changes made to the icon.
If the icon is new, the Save icon dialog box is displayed, enabling you to specify a name for
the icon file.

Save As
Saves a new or existing icon.
The Save icon dialog box is displayed whether the icon is new or one selected from the 
IconWorks Viewer.

Exit
Closes the IconWorks Editor.
 If any of the six icons in the Status area were changed since they were last saved, you are
given the option of cancelling the Exit command.    If the Viewer is currently open but the 
Editor was started first, you are asked if you want to also close the Viewer.    If the Viewer 
was started first (command line argument of "V" or "v"), the Editor is closed leaving the 
Viewer running.



Edit Menu - Editor
Undo

Reverses changes made to the icon since the last tool change.      Selecting a new tool or 
icon from the Status area commits whatever is displayed in the editing area to the Iconbox 
in the Status area.    The Undo icon button in the Status area always displays what has 
been committed so far.

Cut
Copies the current selection from your icon onto the Clipboard, erasing previous Clipboard 
contents, and clearing the selection area to the currently selected screen color.    A 
selection cannot be cut if it is being moved.    The Cut command is unavailable in this case.

Copy
Copies the current selection from your icon onto the Clipboard, erasing previous Clipboard 
contents, leaving the icon selection area displayed.    A selection cannot be copied if it is 
being moved.    The Copy command is unavailable in this case.

Paste
Inserts the Clipboard contents in the the upper-left corner of the editing area, allowing you 
to move the pasted bitmap to any location within the area before it is commited.    A mask 
is created for the bitmap being pasted, so the effect of pasting non-rectangular bitmaps 
can be achieved.    All pixels in the pasted bitmap that match the currently selected screen 
color are given the screen attribute; therefore will appear transparent and do not affect 
what is below them.        Inverse screen attributes are not retained, so pixels matching the 
inverse of the screen color become foreground pixels.

Paste Opaque
Inserts the Clipboard contents in the the upper-left corner of the editing area, allowing you 
to move the pasted bitmap to any location within the area before it is committed.    A 
bitmap is pasted as is.    No mask is created, so all pixels in the bitmap are treated as 
foreground pixels and cover any pixels below them.

Delete
Clears the selection in the editing area to the currently selected screen color, leaving the 
the Clipboard contents intact.

Select All
Selects the entire icon.    Double-clicking the Select tool performs the same operation.

Flip Horizontal
 Flips the current selection from side to side.

 

Flip Vertical
Flips the current selection from top to bottom.



Rotate Right 90 degrees
Rotates the current selection 90 degrees to the left.

Rotate Left 90 degrees
Rotates the current selection 90 degrees to the right.

Invert
Inverts all of the colors in the current selection.    Black becomes white, white becomes 
black, and so on.



View Menu - Editor
Status Bar

Hides or displays the Status area.    If the Editor is too small to display the Status area, this 
command is unavailable.

Tool Palette
Hides or displays the Tool Palette.    If the Editor is too small to display the Tool Palette, this 
command is unavailable.

Color Palette
Hides or displays the Color Palette.    If the Editor is too small to display the color palette, 
this command is unavailable.

Zooming Scroll bar
Hides or displays the Zooming Scroll bar.

Show All
Diplays all currently hidden Editor controls: The Status area, Tool Palette, Color Palette, and
Zooming Scroll bar.    If the Editor is too small to display a specific control, it will remain 
hidden.

Grid
Turns the grid on or off..    Distinguishing between individual pixels is easier when the grid 
is on.

Line Grid
Sets the grid type to line.

Dotted Grid
Sets the grid type to dotted.

Zoom In
Zooms in on the current icon, making the magnified icon larger in the editing area.    
Performs the same function as clicking the down arrow or below the slider of the Zooming 
Scroll bar.

Zoom Out
Zooms out from the current icon, making the magnified icon smaller in the editing area.    
Performs the same function as clicking the up arrow or above the slider of the Zooming 
Scroll bar.

Focus to Editor on Drag&Drop
When checked, automatically brings the Editor to the foreground any time an icon is 
dragged from the Viewer and dropped into the Editor.    When unchecked, enables you to 
repeatedly drag icons from the Viewer and to drop them onto the six iconboxes in the 
Status area without bringing the editor to the foreground each time an icon is dropped.

Display Border on Selected Icon



Turns on or off a single-pixel wide border that shows the edge of the currently selected 
icon, in the Status area.

Pop-up Tools menu
Turns on or off the Pop-up Tools menu.    Clicking the Editor anywhere there is not a control, 
or using the right mouse button displays the Tools menu, enabling you to quickly select a 
new tool without going to the Tool Palette (if visible) or opening the Tools menu.



Tools Menu - Editor
Select    Tool Selects a rectangular region.
Paint Tool Paints one pixel at a time.
Fill Tool Fills a region.
Line Tool Draws a line.
Square Tool Draws a square.
Filled Square Tool Draws a filled square.
Circle Tool Draws a circle or ellipse
Filled Circle Tool Draws a filled circle or ellipse



Icons Menu - Editor
Enables you to select and display an icon from the Status area when it is not displayed.

1 - [path]    Filename Selects and displays the icon from the upper-left iconbox.
2 - [path]    Filename Selects and displays the icon from the upper-right icon.
3 - [path]    Filename Selects and displays the icon from the middle-left icon.
4 - [path]    Filename Selects and displays the icon from the middle-right icon.
5 - [path]    Filename Selects and displays the icon from the lower-left icon.
6 - [path]    Filename Selects and displays the icon from the lower-right icon.

The full path and filename of the currently loaded icons are displayed in the corresponding 
menu item.    Selecting an icon from the Icons Menu is equavalent to clicking the 
corresponding iconbox in the Status area.



Color Menu - Editor
Colors

Opens the Custom Color Palette Window Palette window, from which you can define your 
own custom colors and assign them to the current color palette.    You can use the Custom 
Color Palette window to select colors in the same way you select colors with the Color 
Palette displayed in the Editor.    You can display your custom Color Palette as a floating 
palette instead of the Editor's Color Palette.

Default Color Palette
Resets the current Color Palette to the default colors.    That were initially displayed the first
time you ran IconWorks.

INI File Color    Palette
Sets the Color Palette to the values currently stored in the ICONWRKS.INI file.    If this file 
doesn't exist , or you have never saved changes to the displayed Color Palette, the color 
palette is set to the default color palette values

Solid Colors Only
Sets the current color palette to show only solid colors.    All 48 color cells are still 
displayed, but each column of three cells is set to the same color.    Since some tools 
cannot used dithered colors to draw with, this is enables you to ensure that any color you 
select can be used by the selected tool.

Save Color Palette to INI file
Saves the current color palette to ICONWRKS.INI.    If the file does not exist, it is created.

Left/Right Colors
Sets the current mouse colors to those currently displayed in the Status area for the "Left" 
and "Right" colors.    Performs the same function as selecting the corresponding option 
button in the Status area.

Screen/Inverse Colors
Sets the current mouse colors to those currently displayed in the Status area for the 
"Screen" and "Inverse" colors.    Performs the same function as selecting the corresponding
option button in the Status area.



Brush Menu - Editor
Small (1 x 1) Sets drawing tools to 1 pixel wide.
Medium (3 x 3) Sets drawing tools to 3 pixel wide.
Large (5 x 5) Sets drawing tools to 5 pixel wide.

The brush size does not affect the Select    tool or Fill tool.



Status Area

- Highlights the currently selected icon.
- Displays the actual size of the icons currently being edited.
- Enables you to quickly switch between any of six icons by clicking the left mouse button on
the icon you wish to edit.

- Enables you to test how your icon appears when its dragged.
- Enables you to load icons into any of the six icon boxes by dragging the icon from the 
Viewer and dropping it onto an iconbox.

- Displays the current mouse location in the editing area.

- Displays edits that have been committed in the Undo Icon box.

- Displays the currently selected mouse colors.    Enables you to select between forground 
colors or screen and inverse screen colors.

When the Editor is resized with the Status area open, certain items are removed as the 
Editor becomes too small to display all of them.    These items are restored when the Status 
area becomes big enough to display them.    If the Status area is so small that it cannot 
display the six icon boxes, the Status area itself is closed.    In this case, the Status area is 
not automatically redisplayed when the Editor is enlarged; it must be reopened by choosing 
the Status area command from the View menu, or by pressing Ctrl+S.



Tool Palette
 Select    tool Selects a rectangular region.

    Paint tool Paints one pixel at a time.

    Fill tool Fills a region.

    Line tool Draws a line

    Square tool Draws a square.

    Filled Square tool Draws a filled square.

    Circle tool Draws a circle or ellipes

    Filled Circle tool Draws a filled circle or ellipes



Color Palette
Clicking a color cell with the left mouse button selects the color to be used when drawing 
with the left mouse button.    Clicking any color cell with the right mouse button selects the 
color to be used when drawing with the right mouse button.

Double-clicking a cell with either the left or right mouse buttton assigns that color to the 
button that was clicked.    Double-clicking also oepns the Custom Color Palette Window from 
which you can define and set your own colors.



Defining Colors
The Custom Color Palette window is opened by either double-clicking the Editor's Color 
Palette or    by choosing the Colors command form the Color menu.

You can use the RGB scroll bars to set the individual color elements, or you can enter them 
directly from the keyboard into the RGB entry fields.    The three color cells to the right of the
RGB entry fields always display the actual colors for the value of the corresponding RGB 
values.

The "Selected Color" cell displays the current RGB color which is the result of combining the 
individual RGB elements.    Since some of the tools cannot use dithered colors, the Nearest 
Solid Color is also displayed.

To add a color to the Color Palette, choose Set.    The currently selected color cell will be 
updated to display the newly-defined color.    

Choosing Reset before Set sets the RGB values back to the initial color values for the 
currently selected color cell.

To define another color, click on the Color Palette in the Custom Color window, or on the 
Editor's Color Palette.    The Scroll bars, entry fields, RGB color elements, Selected Color, and 
Nearest Solid Color cells are updated to display the values of the selected color, readying it 
to be modified.

Minimizing the Editor hides the Custom Color Palette window.
Closing the Editor also closes the Custom Color Palette window.



Screen/Inverse Colors
Only solid colors can be set for the Screen and inverse screen colors.    However, the color 
you select when designing an icon may not be what you'll see when the the Icon is attached 
to an application and then minimized.    An icon colored with the screen color is transparent, 
displaying whatever is below.    An icon colored with the inverse screen color is transparent, 
but whatever is below is inverted.

When selecting a color for either the Screen or Inverse Screen color from the Color Palette, 
the other is automatically set to the inverse of the other, ie. if you set the screen color to 
black then the inverse screen color is set to white.

While designing an icon, you can test its transparency state by dragging it from the Status 
area.



Undo Icon
The Undo Icon button, which is displayed on the Status area, displays edits that have been 
committed.    Clicking the Undo Icon button performs the same action as choosing the Undo 
command from the Edit menu.

Depending on the size of the Status area (which depends on the size of the Editor), the Undo
Icon button may not be displayed.    If it is hidden, resize the Editor to display more of the 
Status area.



Zooming In and Out 
The scroll bar which appears to the left of the editing area is used to increase or decrease 
the magnification of the currently selected icon.

The icon can be displayed in its actual size or magnified to fill the editing area.    When the 
Editor is resized, the scrollbars range is recalculated for the new size.    The editing area is 
automatically resized to fit the size of the icon it displays.



Moving A Selection
Once a region in the icon has been selected with the Select    tool, there are two ways to 
move it:

Opaque Move - using the right mouse button to click and drag (Move) the selection .    The 
selection is moved as is, including all foreground colored pixels and all 
screen and inverse screen colored pixels.

Transparent Move - using the left mouse button to click and drag (Move) the selection .    
Only the foreground colored pixels are moved.    This enables you to 
move regions in the icon that appear to be a non-rectangular.

Once a selection has been moved, the selection rectangle changes from a dotted rectangle 
to a solid rectangle.    In this state, certain Editing operation are not available.

Holding down the Shift key while moving a selection make a copy of the selection at its 
current location before moving it.    Selecting another tool or selecting another icon also 
commits the moved selection to its current location.



Flipping a Selection
Once a region in the icon has been selected with the Select    tool, you can flip it either 
vertically or horizontally by using either the Edit menu commands or their accelerator keys:

Ctrl+H: Flip Horizontal
Ctrl+V: Flip Vertical

The selection does not have to be square in order to be flipped.    You can also flip a selection
while it is being moved.



Rotating a Selection
Once a region in the icon has been selected with the Select    tool, you can rotate it 90 
degrees to the left or right by using either the Edit menu commands or thier accelerator 
keys:

Ctrl+R: Rotate Right
Ctrl+L: Rotate Left

The selection must be square in oder to be rotated.    A selection that is being moved cannot 
be rotated.



Testing your Icon
While drawing or modifying an icon, tou can see what it will look like when being dragged..    
This is useful to test the transparent portions of your icon.

 To test you icon, click-and-drag the icon from the Status area.    You can test only the 
currently selected icon.    While testing your icon, you cannot drop it..



Select Tool
 Selects a rectangular region.

To use the Select tool, select it either by clicking it in the Tool Palette or by choosing it from 
the Tools menu.    Move into the editing area and press either the left or right mouse button 
to anchor one corner of the flexible box.    Drag the mouse until the box encloses the area 
that you want selected.    Release the mouse button.

If you make a mistake while making a selection, click either mouse button outside of the 
selection and start over.



Paint Tool
 Paints one pixel at a time.

To use the Paint tool, select it either by clicking it in the Tool Palette or by choosing it from 
the Tools menu.    Move into the editing area and press either mouse button to begin 
painting.

The brush size determines how many pixels are painted for each click or movement of the 
Paint tool in the editing area.



Fill Tool
 Fills a closed area with the currently selected color.

To use the Fill tool, select it either by clicking it in the Tool Palette or by choosing it from the 
Tools menu.      Move into the editing area and click either mouse button in the area to be 
filled.    The area will be filled with the color corresponding to the mouse button clicked, as 
specified in the Color Palette.

The Fill tool performs a surface flood fill,    it fills over only adjacent pixels which are of the 
same color as the starting point.

If you fill an area with a dithered color rather than solid color, the result will be a 
checkerboard pattern.



Line Tool
 Draw a line.

To use the Line tool, select it either by clicking it in the Tool Palette or by choosing it from the
Tools menu.    Move into the editing area and press either mouse button to anchor one end of
the line, and drag.    A flexible line stretches from the anchored end to the mouse position.    
When the line is the size you want, release the mouse button to paste it down.    The line will 
then be redisplayed to reflect its actual size corresponding to the current magnification of 
the icon.

To draw a horizontal, vertical, or diagonal line, hold down the Shift key as you drag the 
mouse.

The color of the line is determined by the mouse button used to draw it, as specified int the 
Color Palette.

The brush size determines width of the line.



Square Tool
 Draws a square.

To use the Square tool, select it either by clicking it in the Tool Palette or by choosing it from 
the Tools menu.    Move into the editing area, press either mouse button and drag.    A flexible
box stretches from the anchor point to the mouse position.    When the box is the size you 
want, release the mouse button.

To draw a perfect square, hold down the Shift key as you drag the mouse.

The brush size determines width of the box's border.

The color of the square is determined by the mouse button used to draw it, as specified int 
the Color Palette.



Filled Square Tool
 Draws a filled square.

To use the Filled Square tool, select it either by clicking it in the Tool Palette or by choosing it 
from the Tools menu.    Move into the editing area, press either mouse button and drag.      A 
flexible box stretches from the anchor point to the mouse position.    When the box is the size
you want, release the mouse button.

To draw a perfect square, hold down the Shift key as you drag the mouse.

The color of the filled square is determined by the mouse button used to draw it, as specified
int the Color Palette..    Since the border of the square is actually a line and lines cannot be 
drawn using dithered colors, if a dithered color is used, the border of the square will be 
drawn in the nearest solid color.    If you want the entire square to be drawn with a dithered 
color, first draw the square with a solid color then use the Fill tool to fill it in with the desired 
dithered color.



Circle/Ellipse Tool
 Draws a circle or ellipse.

To use the Circle/Ellipse tool, select it either by clicking it in the Tool Palette or by choosing it 
from the Tools menu.    Move into the editing area, press either mouse button and drag.      A 
flexible ellipse enclosed within a flexible box stretches from the anchor point to the mouse 
position.        When the circle or ellipse is the size you want, release the mouse button.    The 
box is displayed while you draw to show the anchor point and current mouse position.      It is 
not displayed when the mouse button is release.

To draw a perfect circle, hold down the Shift key as you drag the mouse.

The brush size deterines the width of the circle's or ellipse's border.

The color of the circle or ellipse is determined by the mouse button used to draw it, as 
specified int the Color Palette..



Filled Circle/Ellipse Tool
 Draws a filled circle or ellipse.

To use the Filled Circle/Ellipse tool, select it either by clicking it in the Tool Palette or choosing
it from the Tools menu.    Move into the editing area, press either mouse button and drag.      
A flexible ellipse enclosed within a flexible box stretches from the anchor point to the mouse 
position.        When the circle or ellipse is the size you want, release the mouse button.    The   
box is displayed while you draw to show the anchor point and current mouse position.    It is 
not displayed when the mouse button is released.

To draw a perfect circle, hold down the Shift key as you drag the mouse.

The color of the circle or ellipse is determined by the mouse button was used to draw it, as 
specified int the Color Palette.      Since the border of a circle or ellipse is actually a line and 
lines cannot be drawn using dithered colors, if a dithered color is used, the border of the 
circle or ellipse will be drawn in the nearest solid color.    If you want the entire circle or 
ellipse to be drawn with a dithered color, first draw the circle ir ellipse using a solid color 
then use the Fill tool to fill it in with the desired dithered color.



Keyboard - Viewer
Press: To choose:

Alt+F4 Close IconWorks Viewer

F7 Open the    Editor (Does not load icon)
Ctrl+V Show all icons

F1 Open Help



Commands - Viewer
File Menu
Edit Menu
Options Menu



File Menu - Viewer
Open:

Opens the IconWorks Editor and loads the currently selected icon, readying it for editing.    
There are several ways to select and load an icon into the Editor.    The menu item is active 
only when an icon is selected.

Exit
Closes the IconWorks Viewer.    If the Editor is open and the Viewer was started first, you 
will be asked if you want to also close the Editor.    If the Editor was started first , the 
Viewer will be closed leaving the Editor running.



Edit Menu - Viewer
Copy

Copies the bitmap image of the selected icon onto the Clipboard, erasing previous 
Clipboard contents.    The icon itself is not copied to the Clipboard.      The Copy command is
unavailable if    no icon is selected.



Options Menu - Viewer
Editor

Opens the IconWorks Editor without loading the selected icon into the Editor.    If necessary,
the Editor is loaded.    If the Editor is already opened, it is brought the foreground.

Show all icons
Displays all of the icons listed in the Icons list box within the scrollable viewing window to 
the right of the list box.

Show all icons on DIR Change Command
If selected, a "Show all icons" operation is automatically performed when the directory is 
changed if the new directory contains any files.



Viewing Icons
You can view individual icons one at a time, by selecting them from the Icons list box .    The 
selected icon is displayed just above the list box. next to the label "Selected Icon".

To view all the icons at the same time, choose the Show all icons command    from the 
Options menu.    Each of the icons in the current directory is displayed in the viewing window
to the right of the list .    The viewing window is scrollable, so if there are more icons than can
be displayed at one time in the viewing window, a scroll bar appears enabling scrolling 
through the icons.    The Viewer can also be resized to increase the size of the viewing area 
to allow more icons to be visible at once.

If the directory is changed while icons are displayed in the viewing window, the window is 
cleared.

Any files in the currentl directory that are not valid Windows 3.0 Icons appear as solid black 
squares in the viewing area.



Selecting an Icon to Edit
There are several ways an icon be selected from the Viewer and loaded into the editor:

- Dragg the "Selected Icon" from the Viewer and dropit on the Editor's editing area or on one 
of the six    iconboxes in the Status Area.

- Drag an icon from the viewing window and drop it on the Editor's editing area or on one of 
the six iconboxes in the Status Area

- Double-clicking a file in the filename list box.
- Clicking a file in the filename list box and pressing Enter.
- Enter the name directly into the FileName text box and press Enter.
- Select an icon then choose the Open command from the File menu.

An error will occur if you attempt to load an icon that does not have a valid Windows 3.0 icon
format.


